OPenGL

OPenGL
2004-04-14T09:55:10+02:00
2006-11-10T03:40:17+01:00
2022-10-20T04:50:50+02:00
Jimmy
Szevasztok!

A gondom következő:

Van egy játék a Return To Castle WolfEinstein. Namármost, ez a játék azt vette a fejébe, hegy nem akar futni. A hiba az, hogy a Console ablakban a prg kirja, hogy a "Coldn't open OpenGl sub-system".
Mi lehet a hiba, hiszen a egy másik OpenGl-es gém a Quake 3 elindul simán. HELP!!!
Mutasd a teljes hozzászólást!

  • ha XP alatt használod és nincs fent a wolf uj patch-e és az sp1a nem is fog menni. amugy a wolf-ban is quake3 motor dübörög.
    patch:
    http://www.sg.hu/letoltesportal.php?status=linkletoltes&refid=1949
    sp1a:
    ORIGO Szoftverbázis


    ha érdekel egy kis pályacsomag:
    http://www.sg.hu/letoltesportal.php?status=linkletoltes&refid=1571
    Mutasd a teljes hozzászólást!
  • Helló!
    Az volna a kérdésem, hogy lehet-e frissíteni a videókártyákon az OPENGL drivert mert nekem 1.3-as van egy gamehez pedig 1.4 kell. Geforce MX440-em van.
    Köszi: Jocesz
    Mutasd a teljes hozzászólást!
  • biosra gondolsz? úgy ahogy abból a kártyából nem lesz directx9-es úgy nem lesz belőle 1.4-es, de szoftveresen képes futtatni új driverrel.
    Mutasd a teljes hozzászólást!
  • Csövi!
    A megoldás hogy installáld ujra a vga kártyád.Ha nem jön össze akkor más baj lehet.
    Mutasd a teljes hozzászólást!
  • Hi all! Nekem amikor elakarom indítani a játékot egy kis konzolban ezeket írja ki:

    Wolf 1.0 win-x86 Nov 13 2001
    ----- FS_Startup -----
    Current search path:
    C:\PROGRA~1\RETURN~1\main\mp_pak2.pk3 (3 files)
    C:\PROGRA~1\RETURN~1\main\mp_pak1.pk3 (308 files)
    C:\PROGRA~1\RETURN~1\main\mp_pak0.pk3 (783 files)
    C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)
    C:\PROGRA~1\RETURN~1/main

    ----------------------
    5869 files in pk3 files
    execing default.cfg
    couldn't exec language.cfg
    couldn't exec wolfconfig_mp.cfg
    execing autoexec.cfg
    Hunk_Clear: reset the hunk ok
    ...detecting CPU, found AMD w/ 3DNow!
    Bypassing CD checks
    ----- Client Initialization -----
    ----- Initializing Renderer ----
    -------------------------------
    Loaded 680 translation strings from scripts/translation.cfg
    ----- Client Initialization Complete -----
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
    ...setting mode 3: 640 480 FS
    ...using desktop display depth of 32
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ...assuming '3dfxvgl' is a standalone driver
    ...initializing QGL
    ...WARNING: missing Glide installation, assuming no 3Dfx available
    ...shutting down QGL
    ----- CL_Shutdown -----
    RE_Shutdown( 1 )
    -----------------------
    GLW_StartOpenGL() - could not load OpenGL subsystem

    Mi lehet a gond? A segítséget előre is köszi!
    Mutasd a teljes hozzászólást!
  • Szasz!
    Az első hozzászólás pont ugyan az mint a te problémád.
    A második hozzászólás pedig pont ennek a megoldása.


    Salvatore irta:
    ha XP alatt használod és nincs fent a wolf uj patch-e és az sp1a nem is fog menni. amugy a wolf-ban is quake3 motor dübörög.
    patch:
    http://www.sg.hu/letoltesportal.php?status=linkletoltes&refid=1949
    sp1a:
    ORIGO Szoftverbázis


    ha érdekel egy kis pályacsomag:
    http://www.sg.hu/letoltesportal.php?status=linkletoltes&refid=1571


    Egyébként meg http://games.activision.com/games/wolfenstein/
    Mutasd a teljes hozzászólást!
  • Service Pack 2-vel hogyan lehet elinditani a Wolfensteint?????

    Mert Xp-m van.. és csak a SP1-re irtatok dolgokat....
    Mutasd a teljes hozzászólást!
  • Szerintem tegyél fel új videókártya drivert. Én NVIDIA-hoz a 61.77-est tudom javasolni. Bár az újabbak is jók csak nehéz velük felül bírálni a frissítési frekvenciát. Nekem még nem akadtak ilyen gondjaim az RTCW-vel.(XP SP1a és XP SP2 tartalmaz egy alap beépített drivert mely csak Direct3D-t támogat)
    Mutasd a teljes hozzászólást!
  • Pontosítok csak Direct3d-t támogat rendesen és SP installkor lecseréli a feltelepítette, ha nem vagy résen.
    Mutasd a teljes hozzászólást!
  • Kossz a segítséget....
    Mutasd a teljes hozzászólást!
  • Csa sracok,nekem is az a bajom,hogy a Mohaa allied assaultot nem tudom futtatni,mert kiirja,hogy "Could not load OpenGL subsystem"speciel en mit csinaljak?Minden megfelel a gepemen ahhoz hogy jo legyen,ATI Rage 128 Pro kartya,stb.
    Mutasd a teljes hozzászólást!
  • Hacsak nem akarsz PowerPoint slideshow jellegű képet a játéktól, cseréld le a videókártyádat.
    Mutasd a teljes hozzászólást!
  • sziasztok!
    nekem 1 msi nx 7800 xt tipusu vidkarim van amihez kaptam 1 riddick nevű játékot de nem tom elinditani mer 1.3as v jobb opengl kéne hozzá. Mit kéne csinálnom h működjön a game?
    Előre köszi a helpért.
    Tom
    Mutasd a teljes hozzászólást!
  • Na sok év után én is előszedtem az öreg Wolfot... és a hiba
    ...
    GLW_StartOpenGL() - could not load OpenGL subsystem
    ...

    hát az mint a topicnyitónak...
    Mutasd a teljes hozzászólást!
  • Khm megoldottam
    a legújabb NVidia Drivert leszedtem, és megy.
    Mutasd a teljes hozzászólást!
  • Hiába az ATI kártyákhoz mellékelt OpenGL driverek leginkább csak a s**r kategóriákba esnek. Nvidia-val má jobb a helyzet, de ott is mindig a legújabb stabil drivert illik feltenni. De legalább az nvidia oldaláról elég egyszerű leszedni a jó drivereket, míg az ati rendesen eldugja őket.. DE mért is ??
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd