PC Fórum
  • Kisebb betűméret
  • Eredeti betűméret
  • Nagyobb betűméret

Excel - kereső fügvény
50

2013-09-03T03:58+02:00
beem
beemPC Fórum
regisztrált tag
Sziasztok!

Van pár Excel táblázatom amik közt rendet szeretnék csinálni. A számomra fontos elemeket összeraktam egy excel fájlba az A, B, C, D és E oszlopokba.

Az A oszlop tartalmazza az összes lehetséges adatot (ez egy szöveges lista, sok száz bejegyzéssel), a B, C, D és E az A oszlopnak csak részeit tartalmazza.

Szeretnék csinálni egy függvényt, ami megszámolja, hogy az A oszlopban lévő szöveges adat hány másik cellában fordul még elő.

(Tehát, ha csak az A cellában fordul elő, akkor az eredmény 1, ha másik cellában is akkor ahányszor előfordul összesen.)

Illetve el tud valaki irányítani engem egy jó oldalra ahol Excel függvényekről tudnék olvasni/tanulni (Angol, magyar,... minden jöhet). Szeretném egyszer rendesen megtanulni, hogy ne kelljen mindig tőletek kérdeznem. :)
Mutasd a teljes hozzászólást!
Excel - kereső fügvény
2013-09-03T03:58+02:00
beem
beemPC Fórum
regisztrált tag
=DARABTELI(A:E;"*"&A1&"*")

Ez megkeresi a nem teljes cellás egyezéseket is.
Mutasd a teljes hozzászólást!
Oszd meg másokkal is!

Teljes egyezést szeretnél vizsgálni? Tehát azt akarod vizsgálni, hogy az A oszlopban lévő cellákból más vagy ugyanazon tartományban előfordul-e máshol is a keresett érték?
Ha igen, a DARABTELI függvény segít neked ebben.
Mutasd a teljes hozzászólást!
Kipróbáltam ezzel a függvénnyel:
=DARABTELI(A1:E330;A1)
...
=DARABTELI(A1:E330;A328)
...

De csak 1-eseket ad válasznak.

Illetve ezzel is:
=DARABTELI(B1:E330;A1)
...
=DARABTELI(B1:E330;A318)
...
Ami csak 0-kat ad.
Mutasd a teljes hozzászólást!
=DARABTELI(A:E;"*"&A1&"*")

Ez megkeresi a nem teljes cellás egyezéseket is.
Mutasd a teljes hozzászólást!
Előttem szólóhoz csatlakozva - ha jól értjük a problémát, akkor ez kell:

=DARABTELI(B:E;"*"&A1&"*")

Ezt kell a F1 oszlopból lefele húznod. Az üres mezőknél kapsz csak majd nagyobb számot.
Mutasd a teljes hozzászólást!
Igen, a felhasználóval volt a hiba. Néhány cellában volt felesleges szóköz a szöveg mögött, így az oszlopok tartalma nem egyezett teljesen.
Mutasd a teljes hozzászólást!
A TRIM függvény levágja az adatok elejéről és végéről a felesleges szóközöket.
Ha nem találod a meg a függvényeid között, az Eszközök/Bővítménykezelőben kapcsold be az Analysis kezdetűeket. Sok új függvényt kapsz.
Mutasd a teljes hozzászólást!
Oszd meg másokkal is!
Belépés
Regisztráció