Excel - feltételek

Excel - feltételek
2011-05-17T20:32:48+02:00
2011-05-18T21:53:02+02:00
2022-11-01T03:45:34+01:00
Benibububaby
Sziasztok,

egy elég komoly problémával találtam szembe magamat..
Van 3 táblázatom..

az első az alábbi módon épül fel:
számlaszám(számlaosztály);érték forintban;dátum;

a második;
dátum(negyedévente);HUF/USD árfolyam

a harmadik:

számlaosztály;rákönyvelhető értéktartomány dollárban;
ebből 11 sor van, és van, hogy azonos az értéktartomány, pl 5.000$<>50.000$

Azt szeretném elérni, hogy az első táblázat mögött legyen egy oszlop, amely alapján meg tudom állapítani, hogy az adott számlára megfelelő értékű könyvelés történt-t.. tehát OK vagy ROSSZ;
nyilván a forintot a dátum alapján kell dollárosítani..

én dupla pontot adok a megfejtőnek.. :)

köszi
Mutasd a teljes hozzászólást!
Akkor először is csinálj azokból a kötőjeles tartományokból külön oszlopokat. Aztán szerintem az üóresekből csinálj mondjuk 1$-t minimumnak és 1millió dollárt maximumnak.

Utána mehet minden ahogy írtam, a számlák végére nagyvonalakban:
=HA(és(összeg / árfolyam < megkeresett_minimum; összeg / árfolyam < megkeresett_maximum); "OK"; "SOK vagy KEVÉS")
Mutasd a teljes hozzászólást!

  • A számla kibocsátásakor érvényes árfolyam:
    =FKERES(A2;Munka1!A:B;2;IGAZ)
    Ahol A2 a számla kelte, Munka1 pedig az árfolyamos munkalap (második).

    Ha a számlaszám után valóban zárójelben van a számla osztály, akkor ennek kinyerése:
    =KÖZÉP(A1;SZÖVEG.KERES("(";A1)+1;SZÖVEG.KERES(")";A1)-SZÖVEG.KERES("(";A1)-1)
    Ahol A1 a számlaszám.

    Számla osztályhoz tartozó maximális könyvelési érték:
    =FKERES(A1;Munka2!A:B;2;HAMIS)
    Ahol A1 az előző képlet eredménye, Munka 2 pedig a harmadik munkalapod.

    Annak kiírása, hogy egy szám nagyobb-e egy bizonyos küszöbnél:
    =HA(A1 > 1000;"NAGY";"KICSI")

    Innentől már csak össze kell ezeket rakni és kell egy szorzás (vagy osztás) bele.

    Jó munkát!


    Mutasd a teljes hozzászólást!
  • az a baj, ennél kicsit komplikáltabb a dolog.. a zárójelet csak az érthetőség miatt írtam, de leírom számokkal..
    1.tábla
    131; új traktor vétele; 1.500.000 forint; 2010.06.30
    121; föld a traktorhoz; 3.500.000 forint; 2010.07.10
    .
    .
    .

    2.tábla..az árfolyamszámítás nem gond..,

    3.tábla
    XXX
    131; 1.000$-100.000$ között
    .
    .
    121;2500$-50.000$ között..
    .
    .
    stb..
    az a baj, h simán HA fgv-vel nem lehet, mert egy típusú intervallum több számlánál szerepelhet, és vagy egy számlára HA-zok, vagy értékekre, szal érted.. :s valahol meg nincs is maximum érték, csak X $ tól..
    Mutasd a teljes hozzászólást!
  • Akkor először is csinálj azokból a kötőjeles tartományokból külön oszlopokat. Aztán szerintem az üóresekből csinálj mondjuk 1$-t minimumnak és 1millió dollárt maximumnak.

    Utána mehet minden ahogy írtam, a számlák végére nagyvonalakban:
    =HA(és(összeg / árfolyam < megkeresett_minimum; összeg / árfolyam < megkeresett_maximum); "OK"; "SOK vagy KEVÉS")
    Mutasd a teljes hozzászólást!
  • tökéletes
    tesztelve, működik, pontos.. :D

    köszi!
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd