DÁTUM KIÍRÁSA képlettel
2020-01-27T09:40:28+01:00
2020-01-27T16:01:21+01:00
2022-07-18T22:13:37+02:00
Fehersolyom
Sziasztok, olyan kérdésem lenne, hogy lehetséges e képlettel vagy bárhogy Excellel a dátum tartományt kiíratni? Az A oszlopban szerepel a kezdő dátum a B oszlopban a végző dátum. Esetleg, ha lehetséges akkor az se ártana hogyha nincs végző dátum akkor azt folyamatosnak venné.

Előre is köszönöm
Mutasd a teljes hozzászólást!
Csatolt állomány
Szia!
Elég sok feltételnek kell megfelelni, úgyhogy ne nagyon reménykedj egyszerű megoldásban.
Az eredeti mintádnak megfelelő képletek:
Az F3 cellába:

=HA($A3<F$1;HA(ÉS($B3<F$1;$B3<>"");"";F$1);HA($A3>HÓNAP.UTOLSÓ.NAP(F$1;0);"";$A3))
Ez még viszonylag egyszerű,de 
A G3 cellába:

=HA($B3>F$1;HA($A3>F$1;HA($A3>HÓNAP.UTOLSÓ.NAP(F$1;0);"";HA($B3<HÓNAP.UTOLSÓ.NAP(F$1;0);HA($B3="";HÓNAP.UTOLSÓ.NAP(F$1;0);$B3);HÓNAP.UTOLSÓ.NAP(F$1;0)));HA($B3<HÓNAP.UTOLSÓ.NAP(F$1;0);$B3;HÓNAP.UTOLSÓ.NAP(F$1;0)));HA($B3="";HÓNAP.UTOLSÓ.NAP(F$1;0);""))
kerülő már korántsem.
A két képlet húzható lefelé és párosával másolható jobbra.
Az F1 - H1 - J1 stb. cellákban van a hónapok első napja, ahogyan a mintába is tetted.

Üdv.
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd