Excel pihenőidő megléte feltételes formázással, pótlékhoz képlet
2020-08-27T21:18:24+02:00
2020-08-30T19:01:05+02:00
2022-09-10T00:25:29+02:00
t-eszti
Sziasztok!

A segítségeteket szeretném kérni. Adott egy munkaidő nyilvántartás, kezdet, vége adatokkal (csatolva).  Arra szeretnék megoldást, hogy időadatok esetén, ha az előző nap vége és a következő nap kezdete között nincs 11 óra pihenőidő, akkor az adott hibás nap kezdete legyen piros színnel kijelölve, jelölve. 
Csatolva a minta tábla. Itt 08.04-én lesz hiba, tehát ezen a napon a kezdet cella legyen piros.

A másik kérésem egy kicsit bonyolultnak tűnik. Pótlékszámítás. 
Tehát ha a ledolgozott napok 1/3-ában váltakozik a kezdet, és a legkorábbi és legkésőbbi kezdet között van legalább 4 óra, akkor este 6-tól reggel 6-ig számolja ki a pótlékot, ha viszont ez nem teljesül, akkor csak este 22-től reggel 6-ig számolja ki a pótlékot, kivéve az 5-6-ig időt. Pihenőnap, szabadság, betegség, ünnep szavak használata esetén legyen üres.

Köszönök mindenféle segítséget, megoldást!
Mutasd a teljes hozzászólást!
Csatolt állomány

  • Szia t-eszti
    Íme:
    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Szia t-eszti
    Az előző táblázat hibás. Tekintsd tárgytalannak! A pótlékolás számításánál voltam figyelmetlen... 
    ... meg nem is értettem meg elsőre, hogy mit is jelent a "kivéve az 5-6-ig időt" megfogalmazás.
    Szóval észrevettem, javítottam. Íme:
    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Kedves verax,

    nagyon köszönöm. Sokat segítettél. Annyi, hogy az 1/3, valójában 0,33 vagy annál nagyobb kell, hogy legyen, illetve, akkor a reggel 5-6:00-ig terjedő időre is kellene számolnia pótlékot. A tábládban 0,4 esetén számolnia kell este 18-6:00-ig pótlékot, 08.09-én nem teszi ezt meg valamiért.

    Amennyiben a leggyakoribb munkakezdés 0,33-nál kisebb, akkor csak 22:00-6:00-ig jár pótlék, viszont 0,33-nál kisebb esetén a 05:00-06:00-ra nem adunk, ezért kivéve az 5-6:00-ig ebben az esetben.

    Esetleg ez alapján újra tudnád küldeni?

    Hálásan köszönöm a segítségedet!

    Üdv.,
    t-eszti
    Mutasd a teljes hozzászólást!
  • Szia t-esztiT
    A táblázatban nem tizedes törtekkel, hanem természetes törtekkel (pontosabban pozitív egész számokkal elvégzett osztás művelettel) számoltam. A 0,4 (négyszer a tíz alkalomból - 4/10) a példa szerinti munkarend leggyakoribb munkakezdési időpontja. Tehát, ha a leggyakoribb munkakezdés nem éri el a 2/3 gyakoriságot (lásd a képlet első feltétel vizsgálatát), akkor a kevésbé gyakori munkakezdési időpontok összességében meghaladják a maradék 1/3-ot.
    A másik feltételvizsgálat magáért beszél.
    Ha mindkét feltétel kiértékelése IGAZ akkor "elmegyünk az IGAZ ágra".
    Itt korrigáltam a pótlékszámítás képletét.
    Ha legalább az egyik feltétel HAMIS, akkor pedig a HAMIS ágban folytatjuk a munkát.
    Itt is helyesbítettem a képletet.
    Íme a eredmény:
    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Szia t-eszti!

    Egy kis előjáték: :)

    "Tehát, ha a ledolgozott napok egyharmadában változik a kezdet,..."
    Ez azt jelenti, hogy a munkanapok kétharmadában viszont változatlan a munkaidő kezdete.
    Ezért keresem a leggyakoribb munkaidő kezdetet és vizsgálom annak gyakoriságát.
    A példa szerint leggyakoribb kezdet a 12:00 - négyszer fordul elő a tíz munkanap között.
    Ezek szerint ez a négy alkalom a "legállandóbb", tehát ehhez az "állandóhoz" képest a másik hat eset több, mint az esetek egyharmada.
    Logikailag mindegy hogy azt vizsgálom-e, hogy...
    ... az "álladó" kisebb-e, mint kétharmad...
    VAGY
    ... a "váltakozó" nagyobb-egyenlő-e, mint egyharmad.
    Viszont az előbbit technikailag könnyebb kivitelezni.

    ... és a legkorábbi és legkésőbbi kezdet között van legalább négy óra,...
    Ezen azonban tovább "kattogott az agyam". Gondolkodtam a megoldandó helyzeten és az egyharmad - kétharmad kapcsán szöget ütött a fejembe, hogy esetleg nem a munkakezdési időpontok, hanem a munkakezdési négy órás időintervallumok gyakoriságát kellene vizsgálni.

    Így született meg az alábbi táblázat.
    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Kedves verax,

    szuper, nagyon köszönöm!
    Utolsó kérdésem. Mi lenne a képlet akkor, ha azt szeretném, hogy ha Kezdés<6:00:00, akkor adja a 6:00:00-kezdés, ha viszont a kezdés nagyobb, mint 6:00:00, akkor adja a 0 értéket? Az elejéhez eljutottam, de valamiért -6 értéket hoz azoknál a napoknál, ahol 12:00-es a kezdés. 

    Hálásan köszönöm a megoldásokat!

    Üdv.
    t-eszti
    Mutasd a teljes hozzászólást!
  • Szia t-eszti!
    Hová szeretnéd a képletet?
    Így elsőre egy egyszerű HA(Feltétel;Igaz_esetén;Hamis_esetén) elágazás tökéletes lehet.
    Ha küldenél egy mintatáblát, amelybe kézzel beírod a egy-két helyre az eredményt, az egyértelműbbé tenné a kérésedet.

    üdvözlettel
    verax

    utóirat
    Nem írtad, hogy a 6:00 kezdés esetén mi legyen a válasz, úgy kezeltem, hogy <=6:00 esetén 6:00, >6:00 esetén 0:00 az eredmény. Ha nem így értetted, könnyen módisíthatod a képletet az egyenlőségjel eltávolításával.
    Mutasd a teljes hozzászólást!
  • =HA(B6<=6/24;6/24;"0")
    és
    Cellák formázása - Szám fülön Egyéni formátum.
    Formátumkód: ó:pp" - kezdés"
    vagy ha inkább úgy szeretnéd: ó:pp:mm" - kezdés"
    Mutasd a teljes hozzászólást!
  • Kedves verax,

    köszönöm. Csatolom a táblát, hogy mit szeretnék látni. Tehát ha a kezdés kisebb, mint 6, akkor 6 mínusz kezdés legyen az érték. ha nagyobb, mint 6, akkor 0. Az eredményeket beírtam a pótlék oszlopba, ez lehet szám formátum egy tizedessel, vagy ó:pp. Köszönöm!

    üdv.
    t-eszti
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Szia t-eszti!

    A képlet nem bonyolult:
    =HA(B3<=6/24;6/24-B3;0)
    A képletet tartalmazó cella formázására - számformátumára - kell kicsit több figyelmet szentelni.

    üdvözlettel
    verax
    Mutasd a teljes hozzászólást!
  • Kedves verax,

    szuper vagy, nagyon köszönöm a sok-sok segítséget!!!

    üdv.,
    t-eszti
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd