Excvel többszörös HA függvény

Címkék
Excvel többszörös HA függvény
2021-04-26T12:33:41+02:00
2021-04-26T16:48:20+02:00
2022-07-18T22:21:21+02:00
marci672
Sziasztok,

az alábbiban kérném a segítségeteket, amit példával illusztráltam:

Adott egy kb 500 soros táblázat, ahol a B és C oszlopba érkeznek egy képlet alapján az értékek. Jelenleg sok helyen a #HIÁNYZIK értéket adja eredményül a cella, mivel még a képlet nem talált neki megfelelőt (Fkeres függvénnyel keres az A oszlopban található kód alapján egy olyan táblában amibe egy automata folyamat írja be a kódót meg az időpontokat), hiszen még nem töltődtek be az adatok, csak később fognak.

Szeretném az egyes telepítések állapotát megjeleníteni egy új (D) oszlopban, a képen látható módon. Mindhárom próba érték mellé sikerült egy HA függvénnyel megjeleníteni amit a 3 különböző típusból ki szeretnék listázni.

A kérdésem az, hogy miként tudnám megoldani azt, hogy a három eset egy képletbe kerüljön bele úgy, hogy az olyan esetekben is adjon megfelelő eredményt, ha a B vagy C oszlop értékei közül valamelyikében #HIÁNYZIK szerepel?

A lényeg az lenne, hogy ha nincs időpont akkor ne adjon meg semmit, ha csak kezdési időpont van akkor "Telepítés elindult", ha meg van végső időpont akkor  "Sikeres telepítés" jelenjen meg.

A D oszlop celláinak képletei:
D2: =HA(ÜRES(B2);"";"")
D3: =HA(ÜRES(B3);"";"Telepítés elindult")
D4: =HA(C4>B4;"Sikeres telepítés";"")
Mutasd a teljes hozzászólást!
Csatolt állomány
Szia!

Próbáld ki ezt a képletet:

=HA(SZÁMÉRTÉK(E2)>SZÁMÉRTÉK(D2);"Sikeres telepítés";HA(SZÁMÉRTÉK(D2)>SZÁMÉRTÉK(C2);"Telepítés elindult";HA(ÜRES(C2);"";"Tervezett telepítés")))
Üdv.
Mutasd a teljes hozzászólást!

Címkék
abcd