Fkeres függvény külső hivatkozásának címe munkafüzetből véve
2022-01-08T11:45:55+01:00
2022-05-02T14:40:56+02:00
2022-07-18T21:40:23+02:00
Macsi62
Sziasztok!

Adott egy Excel kimutatás, melynek több munkafüzete van, s mindegyikben több 100 fkeres függvény dolgozik, külső Excel kimutatásokra hivatkozva.

Naponta több külső Excel kimutatás adatait kell megkeresni az alapkimutatásba, és ott ellenőrzéseket végezni.

Gondoltam, csinálok egy munkalapot (Adatbázisok), ahova beírom a külső Excel kimutatás elérési útját, s mikor máshonnan kell adatot venni egyszerűen átírom az itt lévő adatokat, s máris mindenhol aktualizálódik az FKERES() az új ellenőrzéshez.

pl.  B5 cella  'C:\Users\csilla\Documents\Elszámolások\2021. évi\egyeztetés.xlsx]Kivonat'!$D$5:$G$201

Gondoltam, elég erre a cellára rámutatni az FKERES() függvényben, s működik a dolog.

=HAHIBA(FKERES($A3;Adatbázisok!B5;2;HAMIS);0)

Sajnos nem működik :(
Ha esetleg lenne erre valami megoldás. hálásan megköszönném.

Üdv. Csilla
Mutasd a teljes hozzászólást!

  • Szia Csilla!

    Két lehetőséged van. Az általad mutatott példa csak abban az esetben fog működni, ha INDIREKT függvénybe ágyazod be a másik munkafüzet nevét és a tartományt, amit használni szeretnél, a következő képpen:
    =INDIREKT("'["&munakfüzet_neve&"]"&munkalap_neve&"'!"&táblahivatkozási_tartománya)
    Ennek a módszernek az előnye, hogy egyszerű, hátránya, hogy csak akkor működik, ha a hivatkozott munkafüzet(ek) nyitva van(nak), egyébként #HIV! hibát fogsz kapni.

    A másik lehetőséged, hogy Power Query (Adatok fül/Adatok beolvasása/Fájlból/Excel munkafüzetből. használatával beolvasod az összes munkafüzetet, és becsatolod őket az aktuális munkafüzetbe, majd a Power Query-vel végzed el a számításokat. 
    Ennek az előnye, hogyha átmozgatják vagy változik a fileok elérési útvonala, akkor azokat a Power Query File/Lehetőségek és beállítások/Adatforrás beállításai ablakban tudod javítani és az minden hivatkozott helyen lecseréli. 

    Üdv:
    Szilárd
    Mutasd a teljes hozzászólást!
  • Köszönöm :)
    Mutasd a teljes hozzászólást!
abcd