Excel adott tartalmú cella címének azonosítása 2
2022-05-03T20:29:26+02:00
2022-05-04T21:47:30+02:00
2022-06-29T08:11:06+02:00
Krisz220503
Sziasztok !

Excellel kezdtem el jobban barátkozni, és nem értem hogy tudok hivatkozni egy oszlopszámra megadott érték alapján?

Azt szeretném, hogy tetszőleges értéket találjon meg egy adott sorban és onnan jöjjön vissza nekem egy valami amit felhasználhatok az oszlop függvénnyel.. de hiába van ott a tartományban az érték, a hol.van függvény semmit az ég világon nem talál meg belőle :S

Mintha nem is létezne a függvény, annyira hasznos.
Létezik bármilyen módja?
persze majd nekem az kell hogy a megtalált oszlopból egy tetszőleges másik adatot adjon vissza, de az oszlop változhat így nem tudom előre melyik oszlopban lesz a keresett adat így a fkeres vagy vkeres függvények csak közvetve jöhetnek szóba.

hogyan tudom kideríteni hogy az adott string a 4.oszlopban található?

Köszönöm!
Mutasd a teljes hozzászólást!

  • Szia!

    A képen látható megoldásra gondolsz?
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Szia,
    Meglehet,
    Csak azt nem ertem te konkretan 1 sorban és 1 oszlopban keresel.. a hol.van függvény csak 1 dimenzióban használható? Olyat nem tud hogy a1:h7 és keresse meg az adott értéket?mert én erre alapoztam hogy ezt kellene valaminek tudnia..

    Akkor hogyan keresek egy értékre ha nem tudom hol.van? Most tudod melyik sorban és oszlopban keresed.. de ha ezt nem tudod és ez a feladat hogy kiderítsd? Mert igazábol ez lenne a küldetés hogy találjuk meg...
    Mutasd a teljes hozzászólást!
  • Tegyél fel egy képet, amin látszik, mit is szeretnél. Legyenek rajta a sor- és oszlopazonosítók is.
    Mutasd a teljes hozzászólást!
  • Szia!

    a hol.van függvény csak 1 dimenzióban használható? 

    Igen, és a kereső függvények ilyenek. VBA-ban van olyan metódus, ami egy adott tartományon belül keres - mint a Ctrl +F -.
    Általában olyan tartományokban használjuk a kereső függvényeket, ahol fej és/vagy oldalrovatok találhatók és azok alapján keresünk értékeket.
    Ha tartományon belüli érték elhelyezkedésére vagy kíváncsi, akkor több egymásba ágyazott keresés hozhat eredményt. Példa a csatolt fájlban.
    Üdv.
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Szia!

    Azért nem reménytelen a helyzet.

    2d keresés

    =SZORZATÖSSZEG((C5:L20=C23)*SOR(C5:L20))-SOR(C5:L20)+1
    =SZORZATÖSSZEG((C5:L20=C23)*OSZLOP(C5:L20))-OSZLOP(C5:L20)+1

    Általánosan:
    =SZORZATÖSSZEG((keresesi_tartomany=az_egyedi_ertek_amit_keresel)*SOR(keresesi_tartomany
    ))-SOR(keresesi_tartomany)+1
    =SZORZATÖSSZEG((keresesi_tartomany=az_egyedi_ertek_amit_keresel)*OSZLOP(keresesi_tartomany ))-OSZLOP(keresesi_tartomany)+1


    Üdv:
    Szilárd
    Mutasd a teljes hozzászólást!
    Csatolt állomány
abcd