Videókártya "összeomlás"

Videókártya "összeomlás"
2022-08-19T16:56:28+02:00
2022-08-28T19:17:28+02:00
2022-11-13T19:10:31+01:00
copy14
Teljesen véletlenszerűen de általában akkor amikor éppen a videókártya komolyabban van használva (pl 4K-s videó vagy 1080p BluRay film) összeomlik a rendszer. Van hogy egy hétig/hónapig semmi, meg van, hogy akár naponta 2-3-szor is. Az egeret tudom mozgatni, illetve letudom tenni tálcára a jelenleg futó ablakokat nagyjából (eléggé laggol ilyenkor) viszont nem tudok új alkalmazásokat megnyitni, nem működik a leállítás, újraindítás gomb és az idő is bevan fagyva. Ilyenkor nehezen, de néha megtudom nyitni a feladatkezelőt és a legutóbbinál a csatolt képen látszik egy pár érdekes adat.

Imgur kép

A 3D a Copy és a Video Decode kb 35%-ról felugrott 100%-ra, a kihasználtság viszont -1%, ezt követően történt a fagyás.

A videókártya nincs overclokolva, és amióta ezek a crashek elég gyakorivá válltak a ventillátorokat is kicsit jobban felhúztam, hátha segít neki valamit.

A videókártyának annyi, kuka vagy ezzel lehet kezdeni valamit?

Setup:
-Tápegység: Cooler Master Elite V3 600W

-Alaplap: ASUS ROG STRIX B450-F

-Processzor: AMD Ryzen 5 2600X Hexa-Core 3.6GHz AM4 Overclocked: 3.8GHz

-Memória: Kingston HyperX FURY 8GB DDR4 2666MHz HX426C16FB3/8

-Videókártya: GIGABYTE GeForce GTX 1050 OC 2GB GDDR5 128bit PCIe

-Operációs rendszer: Windows 10 Pro 64 bit
Mutasd a teljes hozzászólást!

  • Üdv!

    Így elsőre amik eszembe jutnak:

    - a lejátszott film forrását ellenőrizném hátha sérült,
    - a lejátszó program vagy kodek is lehet hibás: ha van, törölj le minden fancy kodek pakkot Revo Uninstallerrel vagy hasonlóval, hogy nyoma se maradjon és próbáld ki az MPC-HC -t (MediaPlayer Classic Home Cinema), mert az kodek nélkül játszik mindent is,
    - Az AMD sosem tudott drivert írni, a VGA drivereik meg híresen kókányak, ezért meg kellene próbálni újabbat vagy régebbit feltenni,
    - a tápegységnek elvileg elégnek kellene lennie, de egy kontakt hibás PCIe csatlakozó tud anomáliákat okozni: én másik PCIe tápcsatlakozót dugnék a kártyára és érzéssel megmozgatnám a a PCIe foglalatban, hátha kilazult. Ugyanígy végigmennék az alaplapra menő, 24 tűs tápcsatlakozón és a CPU 12 voltos segédtápján (persze csak kikapcsolt állapotban),
    - végül de nem utolsósorban: egy haldokló meghajtó (főleg ha azon van a rendszer) is okozhat ilyen adatátviteli megtorpanásokat és megfutásokat. Nézz S.M.A.R.T. adatokat a meghajtóidról!
    Mutasd a teljes hozzászólást!
  • Szia!

    Köszi a gyors választ, megnéztem nagyjából amiket írtál, a következőkre jutottam:

    - Nem a film forrásával vagy a lejátszóval van a baj, van, hogy ugyanannál a filmnél előjön, van, hogy nem. Illetve youtube videóknál is szokta csinálni ezt.
    - Hallottam arról, hogy esetleges problémák szoktak lenni AMD proci és Nvidia GPU közös használatánál, jelenleg a legfrisseb driverek vannak fent, de már több driver frissítés is volt, egyik se javította ezt a hibát, plusz akkor valószínűleg nem csak nekem lenne ilyen problémám, hanem több embernek is, valószínűleg nem ez a ludas.
    - Az alaplapról kap áramot, nem közvetlenül a tápból. Próbáltam ki és beszerelni, ez se oldotta meg sajnos, nem mozog a videókártya a foglalatban. A többi tápcsatlakozó is rendesen bevan dugva.
    - A meghajtóra én is gondoltam már többször, többször is 100%-on megy, nem szereti nagyon a Windows 10-et, viszont a HD Sentinel nem ír semmit sem. (A merevlemez állapota hibátlan. Nem található hibás vagy gyenge szektor, nincsenek felpörgési és adatátviteli hibák sem.) 100%-os kondíció.
    A S.M.A.R.T adatok viszont nekem nem mondanak semmit, esetleg ha valaki ért hozzá bemásolom ide a képet
    S.M.A.R.T adatok
    Mutasd a teljes hozzászólást!
  • Ez egy WD HDD? Intelliparkos? Ha az, akkor 8 másodperc tétlenség után parkoltatja a fejet és utána kell neki idő amíg magához tér, olyankor minden megakad. De ugyanez van az összes energiatakarékos HDD-vel, amik pihenőbe mennek el egy idő után.
    Mutasd a teljes hozzászólást!
  • WDC WD10EZEX-08WN4A0 HDD-m van.
    Igen tapasztaltam már olyat, hogy ott hagytam a gépet egy órára, és amikor visszaültem elé kellett neki egy pár másodperc, hogy összeszedje magát, de nem hiszem hogy egy filmnézésnél tétlenség lenne a probléma, valamint az általam leírt problémakor nem is tér magához, eddig 10 perc volt a max amit vártam, hátha észbekap, de nem, ugyanúgy bevolt fagyva minden, ahhogy leírtam.
    Mutasd a teljes hozzászólást!
  • Kapcsold ki a CPU, memória OC-t, ha van tedd alapra, a rendszert pedig szigorúan
    SSD-re (M.2 ha van az alaplapon) telepítsd Windows 10 illetve 11 esetén.
    Amennyiben meg lesz egy kis zsebpénzed vegyél még egy memóriamodult
    a már meglévő mellé (teljesen ugyanolyat).
    Mutasd a teljes hozzászólást!
  • Helló,

    Hát ez novella lett (első körben arra tippelek hogy behalt az egyik memória chip a kártyán -vagyis ez az utolsó kör csak ide írtam elölre, először pár ingyenes kör...)


    Annyi látni a képen, ha felugrik 100%-ra a decode terhelés akkor reccsen be  (már majdnem azt írtam hogy a 2GB Vram telik meg és akkor de látni hogy annak nincs hozzá köze)

    A GPU Video decode cuccáért a driver felelős (bár abba is be lehet nyúlni)

    #1.1 Driver letölt innen azt írják jó hozzá a legújabb is (ezt a kört talán megúszod -az hosszú lenne hogy visszamenőleg kitudja mennyi drivert letesztelni)
    #1.2 Display driver uninstaller letölt innen
    #1.3 Display driver és az Nvidia driver asztalra kicsomagol
    #1.4 Kártyához való nvidia driver feltesz (bár ehhez a GTX 1050-hez talán még jó a legújabb is)

    #2.1 kicsit megpiszkáljuk ezzel DXVAChecker letölt
    Lehet kelleni fog hozzá ez a 3 cucc is a linkek ott vannak az oldalon: 
    Microsoft .NET Framework 4.6
    Microsoft Visual C++ Runtime x86 (32bit/64bit Windows)
    Microsoft Visual C++ Runtime x64 (64bit Windows)
    #2.2 Amikor elindítod "lent van olyan hogy" driver settings → mindent on-ra (a számokat nem piszkál)

    #3.1 az eléggé nagy probléma hogy encode/decode túlterhelést kellene tesztelni hogy hamar kiderüljön videót kellene konvertálgatni.. annyi betűt most nincs erőm leírni ...(majd ha ezek után nem jön elő a hiba, megpróbáljuk úgy előszedi.. ha akkor sem , akkor csak driver és beállítás gond volt)

    #4.1 Lehet resetelni kellene a böngészőt (vagy csak inkognitó módban nézni tesztnek 4K@60 youtube videókat  legyen kis game videó)
    #4.2 Resetelni kellene azt amit filmlejátszáshoz használsz.. egy ilyen kép simán elviszi a 4K UHD HDR blu-rayt és mkv-t is meg lehetne próbálni mondjuk átállni a mediaplayer-black-re (nálam van mellette madVR-is...vagy 30-40! beállítással -de maradhat alapon is ha nem kell HDR)


    Annyit legalább látni a képen, hogy a kártyád GTX1050 azért tudja dekódolni a VP9-et (youtube 4k) szóval a chip az GP107-es lehet -de most jobban megnézve a GP106-os cip is tudja de csak 8biten!
    ha véletlenül valami HDR annak kell a 10 bit -azt a GP106-os nem tudja -lehet akkor reccsen be?  

    Nézzél már meg pár 4k HDR videót innen (letöltve)  azzal a lejátszóval amit használsz? VLC? hogy bereccsen-e majd a mediaplayer balack-el beállítások nélkül

    De remélem a driver csere/reset megoldja mert ha ez itt lenne előttem és nem sikerülne ez egy jó pár órás kör, és csak kb-ra írtam le. És ha ezek után kiderül hogy nem szoftver hiba.. akkor jön a pénzes/hardveres-de a hkártya hőfok megfelel, a VRAM sincs 100%-on kihasználva , ha meg maga a GPU reccsen be 100%-on (mikor meggondolja magát) az lehet valami áramfelvételi "spike" akármi.. -hogy hirtelen túl sok áram kellene neki -de várjunk csak egy GTX 1050-nek amin 2GB van és nem Ti-annak nem is kell külön tápkábel

    Filmezés közbe lehetne figyelni GPU-z szensor fülön  hogy mennyi áramot vesz fel.

    Jó lenne ide róla screenshot. Meg a videók linkje aminél bereccsen. 

    Mivel a blu-ray 1080 közben is van gond.. lehet valami beállítást kellene a lejátszókban megpiszkálni, mert nálam gyengébb kártyával és CPU-val egy UHD.BD50.2160p.HDR10+DV.x265.Atmos.7.1 -mondjuk ahogy elnézem felszalad a VRAM 2GB-ra nálad meg stabil 500MB és mikor kicsit felmenne akkor ugrik meg a decode és stb..és akkor reccsen be.



    A kártyádon szerintem van 4db 512MB-s VRM chip hát lehet valamelyik elromlott de az úgy már tényleg pénzes kör. -vagy úgy kell beállítani mindent, hogy ne használhasson 512-nél több VRAM-ot de akkor meg minek.

    Megoldható lenne egy olyan screenshot, hogy nézel valamit és a feladatkezelőben vagy a GPU-zben a dedikált memóra ~ 1-1,5 Gb legyen? vagy azonnal bereccsen? -ha nem akkor a VRAM chip a hibás.

    Lehet van videókártyákhoz is olyan mint sima RAM hoz a memtest86.... itt pl találni vagy ez a memtestG80
    Mutasd a teljes hozzászólást!
  • "A kártyádon szerintem van 4db 512MB-s VRM chip..."

    Már az "A" betűnek is annyira felment az ára, hogy csak különösen indokolt esetben használható?
    Mutasd a teljes hozzászólást!

  • Annyit írtam már, hogy kiesett az "A" gomb.. és elvitte az egyik macska. (ja nem itt van csak beleesett a borba)
    Mutasd a teljes hozzászólást!
  • Elnézést, ez nekem nem volt meg.
    Mutasd a teljes hozzászólást!
  • #1 Letöltöttem mindent, telepítés után pár perccel kaptam is egy crasht
    #2 Letöltöttem, elindítottam, de a Driver settings-re nem lehet rákattintani
    Driver settings
    #4.1 Végignéztem egy 10 perces videót. Átlagos százalékok: 3D: 10% (volt amikor pár másodpercig 30% krül volt) Copy: 1-2% Video Encode: 6% Video Decode: 50-60% Átlag hő: 42-45 fok

    A 3D és a Video encode volt hogy többször is felugrott 100%-ra, ezen kívül nem volt vele semmi probléma, tisztán ment a videó, teljesen véletlenszerűek ezek a crashek.

    #4.2 Az alap windows 10-es lejátszót használom, de volt, hogy VLC-t kellett használnom, mert nem ismert fel egy-két filmet és azalatt is volt, hogy behalt. Letöltöttem egy 4k-s videót, azt is VLC-n keresztül nézem, Windows lejátszó nem ismerte fel.
    Nem volt a lejátszás közben semmi probléma
    4K videó alatti adatok

    Lefuttatam egy gyors egész gépes benchmarkot, a GPU tesztelése alatt a dedikált memória átlagban 0.4 GB volt a 2-ből, de nem ment feljebb 0.5-nél.
    Benchmark kép 
    Egyébként ha már megcsináltam itt van a benchmark eredménye is, hátha ez is előrébb visz valamit Benchmark eredmény
    Mutasd a teljes hozzászólást!
  • #1 A GPU-z screenshoton látni, hogy film közben felszalad 1213MB -re a VRAM kihasználtság a kártya 35,8Wattot eszik (a PCI-e sín 75W tud neki leadni)

    Így az a gondolatom, miszerint ha a kártya több VRAM-ot használ mint ~512MB akkor reccs.. mert láthatóan 1213MB használatával is röfögött.

    #2 Az amit futtatál az nem benchmark, hanem egy kókler oldal cucca. (ismerem)

    Unigine Superposition

     Szerintem ez megpűgeti a kártyát hogy a VRAM kihasználtság majdnem 2GB legyen és az áramfelvétel ~72-74Watt  (közben mehet a GPU-z hogy meglegyenek az adatok)

    #3 (Az alap windows mediaplayer sem való semmitől, a VLC már határeset, bár én a Mediaplayer Black-et ajánlanám amit már tegnap is.)

    #4 A DXVA checker driver settings nem tudom miért nem választható (lehet ezt is direkt elrontották, hogy ne tudjon belenyúlni az új driverekbe, nálam is egy régi verzió működik csak ,alig találtam meg... itt van-ja nincs  pár régebbi belőle nálam a 4.1.2-es verzió a legutolsó ami még jó valamire. Perssze.. hogy a legkisebb betű a weboldalon ahol le lehet tölteni , és amint azt választom... file not found. Szépen eltirhították ezt a netről a gyártók mert tudják hogy bele lehet vele nyúlni a driver tiltásokba :)

    No, itt egy régi portable. (enyém) -nézd már meg ezzel is szürke-e a driver settings.
    Mutasd a teljes hozzászólást!
  • #2 Megnyitottam, az 1080p Mediumot ajánlotta, de helyette lefuttattam High-on és Extremen is. Ezalatt és utána sem volt semmilyen gond.
    High Extreme
    Kíváncsigából elindítottam 8K-ban is, de ott a Loading alatt kicrashelt.

    #4 Továbbra is szürke, nem lehet rákattintani
    Mutasd a teljes hozzászólást!
  • A VRAM meg lett hajtva ~2GB fullon használva és nem hibázott akkor VRAM pipa.

    Az áramfelvétel 100% terhelésen is 36W?!  (a solt ugye 75W-t le tud adni.. )
    De szerintem többnek kellene lennie...-  jaaa hogy NVIDIA kártyáknál azonos verziójú GPU-z mást ír.. aha.. (nálam AMD-van... ) nálad a két értéket össze kell adni (board power + PCI-e slot power = 68W) -akkor az áram is rendben, pipa.

    A kártya 3D is 100% ment.. és nem reccsent meg.. akkor az is stimmel, pipa.

    Ezek 3D tesztek nem encode/decode.. szóval most az jön, hogy valamit encode/decode  kellene. Hát erre nem találok benchmarkot. Szóval "élesbe" kellene.

    Kellene egy videó amivel lehet kavarni.. mondjuk egy 4K-s akármi innen.. legyen mondjuk a Samsung CityScape 4K Demo.mp4 817MB 

    (Most ezt én is megcsinálom mert fejből nem megy...a bökkenő az hogy itt AMD VGA van nem NVIDIA)

    Kelleni fog cucc amivel csinálunk belőle mondjuk egy 4k mkv-t de úgy hogy a videókártyát eresszük rá.
    StaxRip 2.13.0


    Program elindít...
    #1 Ráhúzod jobb fentre a videófájlt (ez egy mp4) , aztán beolvassa.. pár másodperc majd újra megjelenik a program ablaka.
    #2 Az x265-re kattintva előjön mivel akarunk encodeolni - nálad ez legyen Nvidia és a H.265 
    (Nálam az AMD H.265 lett ... )
    #3 Megjelenik alatta az encoder options
    #3.1 Basic / decoder → itt nálad szerintem  nem is lesz, (mert lapból az van) ha mégis választható akkor NVEnc legyen a decoder  
    (nálam az AMD miatt ez VCEEnc a decoder pedig VCEEnc(VCE) -így meghajtja kódolásnál a videókártya encode és decode cuccát is 100%-on)
    #4 Leokézod, majd Add job.. a felugró ablakban pedig start
    Valami ilyesmit kellene látnod ha csak simán a feladatkezelővel nézed

    Na ha ettől sem reccsen meg, hogy 100% megy egyszerre az encode és a decode akkor csak nem a kártyával van gond hanem a chrome és a filmézegetős szoftvereiddel vagy a driverrel -de azok legalább ingyenes körök. (ha megreccsen akkor  sem hiszem hogy hardveres a problem, driver környékén lehet valami azért lenne jó ha bele tudna nyúlni DXVA checker)



    Vagy visszamenőleg az összes nvidia drivert letesztelni de az hosszadalmas.. drivergyalu.. régebbit fel ugyan ez a staxrip-es kör..és így tovább ameddig jó nem lesz.
    Mutasd a teljes hozzászólást!
  • Elindítottam a programot úgy ahogy írtad, ez csak az encodeot pörgette 100%-on. Itt nem volt semmi probléma. Aztán találtam egy beállítást ahol az output decodert átraktam NVEnc hardware-re. Ez már a decode-ot is 60%-on használta. Látszólag ezzel sem volt semmi gond. Pont akartam írni, hogy ez is ment rendesen, amikor kicrashelt a szokásosan. Gép resi és utána újra futtattam mindent, akkor semmi baja nem volt.

    Nem írtam le, mert mostanában nem játszok részben ez a hiba miatt, de játékok alatt is előszokott jönni. pl GTA V vagy ami gyakoribb, hogy CS:GO közben miközben haverokkal beszélek Discordon. Egyszer csak megnémul mindenki, lefagy a játék, és látom, hogy a DC beveszi a hangom, amikor beszélek, de nem kapok rá választ, és igazából a többiek nem is hallanak. És akkor ugyanaz a crash amit fentebb leírtam.
    Mutasd a teljes hozzászólást!
  • No, akkor mostmár bebizonyosodott, hogy a decode-nál hibázik (játékokban is vannak átvezető videók azt is dekódolni kell.. vagy kitudja még miket a háttérben lehet akkor crashel pont  vagy nem is tudom)

    Mikor nálam hasonló probléma volt.. (egér mozog, de minden fagyott ... vagy nagyon lassú az egér mondom mi a fene csinálhatja olyan mintha egy "réteg" lefedte volna az asztalt..   Mondom ugyan mi lehet.  (de ez akkor kezdődött mikor a pokerstars beépítette a szoftverébe, hogy induljon vele együtt a háttérben az xbox gamebar is. tán az nvidiának is van valami hasonló Nvidia shadow play? -na azt lehet el lehetne tirhítani, vagy mikor megkérdezi installnál hogy kell-e azt kihagyni) 

    Mondom ilyen nincs viszi itt a pénzem mert elrontottak valamit szoftveresen...

    Fogtam a xbox gamebart és lekaptam  (aztán viszatettem a windows store-ból persze hiba előjött megint):

    #1 Jobb klick a startmenü windows ikonra
    #2 Windows PowerShell rendszergazdaként
    #3 Get-AppxPackage *xbox* | Remove-AppxPackage

    Lehet elég csak simán kikapcsolni. (hátha valami majd visszakapcsolgassa.. szóval inkább powershelles eltávolítás lett. Azóta mióta nincs nincs vele probléma:)


    A másik ötlet, visszamenőleg, régi driverekkel próbálkozni.
    #1 ki kellene kapcsolni hogy a windows ne frissítse le a videókártya drivert és bersze az nvidia driverben is hogy ne frissülgessen Szerintem az O&O Shutup jobb, azzal egyszerű tiltogatni dolgokat de manuálban is meg lehet oldani:

    Win+R
    gpedit.msc
    Számítógép konfigurációja
    Felügyeleti sablonok
    Windows összetevők
    Windows Update
    (a jobb oldalon pedig) → Illesztőprogramok kihagyása a Windows Frissítésekből -ezt kell engedélyezni

    A videókártya drivert le kellene szedni, "nagyon"
    A displaydriver uninstallerrel (ezt letöltés után az asztalra csomagold ki)
    Le kellene töltögetni elég sok NVIDIA WHQL drivert (azokat is kipakolászni kicsomagolva az asztalra, mondjuk a legutolsó 10db-t)
    Az a baj itt van ~96 verzió  ha a driver a gond addig kellene visszamenni a driverekkel ameddig meg nem szűnik a probléma, ha szerencséd van csak 3-4 verziót elég visszaugrani.

    #1 A windowst úgy újraindítani hogy legyen nyomva a Shift miközben az újra indításra kattintasz
    #2 Előjön a win 10 speciális indító menü, helyreállítás/speciális akármi/ indítási beállítások és majd felugrik egy ablak mikor indul, ott a 4-es gombal a csökkentettmód
    #3  A win így elindul csökkentett módban a display driver uninstallerrel most lehet gyalulni
    #4 jöhet a restart, de ez már normál módba
    #5 és jöhet az egyel régebbi NVIDIA driver...
    #6 ha kész, a gép újraindít
    #7 és akkor most jöhet a staxripes encode/decode kör (hogy kiperegjen a decode) akár többször is
    #8/A) Ha nem jön elő a problem akkor a sikeresen a szőnyeg alá lett söpörve
    #8/B) Ha előjön akkor kezdeni az első lépéssel.. az a baj hogy egy ilyen kör ~1 óra

    A drivereket amik nem váltak be majd azért törölgesd közbe nehogy 2x ugyan arra a rosszra pazarold az időt.

    Majd még visszanézek errefelé, hátha valamelyik régi driver segített és akkor nem kell többet tippelgetni, hogy miért pont csak akkor recscen be a kártya mikor dekódolni kell valami média cuccot (játékokban is kell néha médiacuccot dekódolni..)
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Letöröltem a Shadowplay-t meg az xbox gamebart is, kipróbáltam egy pár drivert de sajnos ezek se segítettek.

    Megpróbálok összegyűjteni egy új kártyára inkább, és ha azután is fent áll a hiba, akkor folytatom ezt a témát, vagy nyitok egy újat.
    Mutasd a teljes hozzászólást!
  • Szerencsédre mostanában olcsók a kártyák.
    Mutasd a teljes hozzászólást!
  • Újratelepítettem lassan egy hete a számítógépeket és érdekes dolgokat figyeltem meg.

    Először letöltöttem a Driver booster nevű alkalmazást, egyszerűbb megnyomni egy gombot, és automatikusan leszed mindent, mint nekem egyesével. Ezután egyből crashelt a gép a szokásosan. Valamiért letörölte a LAn drivert és az istenért sem sikerült visszarakni, ezért újratelepítettem az egész rendszert viszont most én szedtem le a gigabyte weboldaláról a drivert. És jónak tűnt minden, nem volt crash, semmi nyoma sem volt, hogy lett volna valaha bármi baja is a videókártyának. Majd jött a windows update, letöltöttem, és utána észrevettem hogy a driver más, máshogyan nézett ki és ez után ismét crashelt az egész. Szóval leszedtem újra a régi drivert, plusz mellé az nvidia oldaláról a game ready drivert. Azóta egyszer se történt crash, pedig rendszeresen nézek sorozatot, ami alatt eddig mindig problémák voltak. 

    A driver verziója 2017-es volt, erre telepítettem rá a legújabb game ready drivert.
    Mutasd a teljes hozzászólást!
  • A Driver Booster és társait messze kerüld, mert amikor eltávolítod a gépről cserébe
    lassulással "jutalmaz", sose használj ilyen "driver medzsik" programokat, pont emiatt.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd