Excel Képlet segítség
2022-09-06T13:50:35+02:00
2022-09-07T07:13:31+02:00
2022-09-07T14:48:22+02:00
Szűcs Regina
Sziasztok!

Adott két munkalap, A munkalapon az összegek bizonyos gyűjtőkhöz és főkönyvi számokhoz   kapcsolódnak, amit a cél munkalapba szeretnék függvénnyel bemásoltatni, ezidáig hiábavaló módon.

Így írnám le:
Ha A oszlop tartalmazza ezt az értéket"11S101S101" és a B oszlop tartalmazza ezt az értéket"053113", akkor másolja be az ezek keresztmetszetében szereplő értéket, ezerre kerekítve.

Köszönöm, ha valaki tudna ebben segíteni!
Mutasd a teljes hozzászólást!
Csatolt állomány

  • Szia,
    a minta táblázatod alapján én a következőt tenném:
    - az oszlopokhoz írj fejlécet: A1: Összeg, B1: Főkönyv, C1: Gyűjtő, D1: Kerekösszeg
    - a C3 oszlopba másold be ezt a képletet: =HA(BAL(A2;13)="Egyedi gyűjtő";A2;HA(BAL(A3;13)="Egyedi gyűjtő";"";C2))
    - így a C oszlopban minden sorhoz előáll a hozzá tartozó Egyedi gyűjtő is, ebből majd készíthetsz kimutatás táblát
    - a D3 oszlopba képlettel az ezerre kerekített összeget kellene tenni. Képlet: =HA(SZÁM(A3);KEREKÍTÉS(A3;-3)/1000;"")
    - a C3 és D3 képletét másold le az adatok végéig
    az lehetne probléma, hogy az adatokat soronként kerekíted 1000 Ft-ra, ezért ha egy gyűjtő alatt ugyanaz a főkönyv többször fordul elő a a kimutatás a kerekített összegeket fogja összeadni (pl. 1650+1650=3300, külön kerekítve 2000+2000=4000 lenne)

    Kimutatás készítése:
    Beszúrás menünél Kimutatás kiválasztása, megadod a tartományt (A:D) és új munkalapra készüljön.
    Utána a jobb oldalon a Kimutatásmezőknél a Sorok alá lehúzod a Főkönyv mezőt, az Oszlopokhoz húzod a Gyűjtő mezőt és az Értékek alá a Kerekösszeg mezőt. Az Értékek alatt, ha nem Összeg / Kerekösszeg jelenik meg, akkor megnyitod a mellette lévő lefelé nyíllal a menüjét és a listából az Értékmező beállítások menüponttal megnyíló ablakban kiválasztod, hogy Összeg.

    A Gyűjtőt teheted a Szűrők alá az Oszlopok helyett, akkor B1-ben listából választhatod az egyedi gyűjtőket és alatta csak az ahhoz tartozó Főkönyv és Kerekösszeg adatok jelennek meg.

    A Gyűjtő és a Főkönyv melletti szűrő ikonnál az Üres értékeket érdemes kikapcsolni. Ha benne marad nem okoz problémát, csak felesleges.

    A mellékelt fájlodban megcsináltam a fentieket, csatoltam a módosított változatot.
    Mutasd a teljes hozzászólást!
    Csatolt állomány
  • Szia!
    Kicsit banántosra sikerült a kérdés: Szerinted 

    Ha A oszlop tartalmazza ezt az értéket"11S101S101" és a B oszlop tartalmazza ezt az értéket"053113", akkor másolja be az ezek keresztmetszetében szereplő értéket

    hol metszi egymást két oszlop az Excelben?
    Így csak találgatni lehet, mit is szeretnél. Egy ilyet találsz az előző hozzászólásban.
    Ha nem arra gondoltál, akkor légy szíves pontosítsd a kérdésed.
    Üdv.
    Mutasd a teljes hozzászólást!
  • Szia!

    A D3 képletét kiegészíteném:
    =HA(ÉS(BAL(B3;6)="053113";SZÁM(A3));KEREKÍTÉS(A3;-3)/1000;"")
    ekkor csak azok a számok jelennek meg a D oszlopban, ahol a B oszlop megfelel a feltételnek, miszerint tartalmazza a "053113" értéket.

    Van "Excelesebb" megoldás. Az adatokat átrendezném a csatolt kép szerint. Ebben az esetben könnyű szűrni az A és B oszlopok szerint az adatokat. A D3 képlete hozza a kívánt adatokat szűrés nélkül is.

    Üdv
    Mutasd a teljes hozzászólást!
    Csatolt állomány
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd