XP + Apache2.2 + PHP5

XP + Apache2.2 + PHP5
2007-07-15T23:33:02+02:00
2007-07-18T12:41:09+02:00
2022-10-21T11:42:04+02:00
netom
Sziasztok!

Windows XP SP2 alá próbálok Apache 2.2.4-et feltenni. Ez megy is tökéletesen, statikus oldalak kiszolgálása rendben.

PHP5.2.3 telepítése is rendben, alapból kikapcsolok minden extension-t.

Ilyenkor a PHP kiszolgálása is működik.

Most jön a csel:

Ha megpróbálok engedélyezni valamilyen kiterjesztést (mondjuk mysql.dll), akkor az apache újraindításkol beleköp a logba:

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\web\\PHP\\ext\\php_mysql.dll' - A megadott modul nem tal\xe1lhat\xf3.\r\n in Unknown on line 0

Az Apache2.2 serice alapból ugye "helyi szolgáltatás"-ként indul, ha beállítom, hogy a "netom" user-ként (jómagam, rendszergazda jogokkal) fusson, akor minden OK, betölti a mysql.dll-t, és működik.

Ez miért van?

Köszönöm szépen.
Mutasd a teljes hozzászólást!
A php mappájában van egy libmysql.dll fájl. Ezt másold be a C:\WINDOWS\system32 mappába, és akkor menni fog, ha nem, írj!
Mutasd a teljes hozzászólást!

Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd