MS Excel - HA függvény alkalmazása tartományon
2008-04-09T19:43:50+02:00
2008-04-09T20:01:08+02:00
2022-07-22T11:36:26+02:00
exibit
Hi all!

A kérdésem a Misrosoft Excel táblázatkezelő program 2007-es verziójával kapcsolatos, bár szerintem a válasz lényege korábbi változatok esetében is megoldást jelentene a problémámra.

Rendelkezésemre áll egy 4 oszlopos, 41 soros, azaz egy viszonylag sok adatot tartalmazó táblázat, melynek 5. oszlopának 2. (E2) cellájában az E2 = HA(C2 < D2;D2 - C2 + 1;(13 - C2) + D2) képlet szerinti értéknek kell állni, viszont a feladat nem csupán ennyi, hiszen ezt mind a 40 adatot tartalmazó sor esetében el kell végezni, azaz be kellene helyettesíteni az adott sor celláinak számával, ami 40 esetben meglehetősen sok. Feltételezem, hogy lehetséges egy bizonyos, jelen esetben az E2; E41 tartományon kiíratni a megfelelő értéket minden cellába a C2; C41 és a D2; D41 tartományba eső cellákban szereplő adatok felhasználásával. Tehát ennek elvégzése után az E38-as cellában az a szám álljon, amit a HA(C38 < D38;D38 - C38 + 1;(13 - C38) + D38) képlet ad.

Hogyan alkalmazhatom tehát a HA függvényt egy tartományon ahelyett, hogy minden cellára megírnám a képletet?

Köszönöm!
Mutasd a teljes hozzászólást!
Úgy hogy másolod.

---
De az adott sor celláinak a száma állandó (256 vagy 18384)


De az aktuális sor sorszáma a sor() függvénnyel érhető el. (Bár szerintem neked valami $-os (vegyes vagy abszolult) hivatkozás kellene)
Mutasd a teljes hozzászólást!

  • Jaj, de idióta vagyok, hogy ilyen bonyolultként és magasfokú ismereteket igénylőként tettem fel egy olyan kérdést, amire a válasz valójában csak annyi, hogy az E2 cella jobb alsó sarkában látható fekete kis négyzetnél fogva lefelé kell húzni az egeret azokon a cellákon át, amelyek az E2-re alkalmazott művelet vagy függvény alapján várnak egy értéket a saját soruk C és D betüjelű celláiban tárolt adatok szerint.
    Mutasd a teljes hozzászólást!
Tetszett amit olvastál? Szeretnél a jövőben is értesülni a hasonló érdekességekről?
abcd