Ububtu 9.10 Samba megosztás probléma
2010-01-31T14:14:13+01:00
2010-02-01T12:53:34+01:00
2022-07-19T02:41:14+02:00
Tomee80
A problémám a következő: Egy ügyviteli programhoz fájlszervert kell telepítenem, fel is tettem az Ubuntu Linux 9.10-t, feltelepítettem rá a Sambát is. A szerverben van 1 db 80 GB-os vinyó azon van a Linux rendszer + van benne egy 500 GB-os amit meg kellene osztanom Sambával. Ha a home/user könyvtárban osztok meg egy mappát akkor minden szép és jó, oda vissza lehet másolgatni, viszont azt nem tudom beállítani, hogy ami azon kívül van mountolva (jelen esetben az 500 gigás vinyó) azt is lássák a hálózatba kötött XP-s gépek.
Végigrágtam már a fél Google-t, de még mindig nem jöttem ár mi lehet a baj? Biztos csak valami apróság, de én nem vagyok valami nagy Linuxos. Nem jutok dűlőre vele. Légyszi segítsetek.
A mountolást egyébként nem lehet automatikussá tenni? Valahogy úgy képzeltem el, hogy se billentyű se egér se monitor nem lenne csatlakoztatva a géphez, reggel bekattintanák, este meg ki. Ez is megoldható így?
Mutasd a teljes hozzászólást!

Use
create mask = 0664
security mask = 0664
directory mask = 0775
directory security mask = 0775
Mutasd a teljes hozzászólást!

  • Szia!

    Lehet, hogy félreértelek!

    Szóval:

    1) Mi a fő szervered? (Windows2000 - 2003 - 2008). Gondolom nem az Ubuntu 9.10!

    2) A Linux valóban egy jó döntés volt (fájlszervernek).

    3) A Főszerverre felvetted mint új felhasználót a Linux-ot?

    4) A Windows XXXX serverre való belépéskor, szerintem nem tudod elkerülni azt, hogy a TE programod ami az (tehát az Ubuntu 9.10) fut, ne kérjen egy FELHASZNÁLÓNEVET és egy JELSZÓT ezt még plusz a Wndows Szerverbe való bejelentkezés után gondoltam. Végül is itt MOUNTOL-ja be a felhasználó az Ubuntu szervereden lévő könyvtár(ak) [program+adatbázisok] tartalmát.

    5) Véletlenül nem VISUAL FOXPRO-s a programod? Ez csak egy megérzés részemről (de lehet, hogy tévedek).
    Mutasd a teljes hozzászólást!
  • Szia!

    Bocs tényleg elég rosszul írtam le, azért értetted félre.
    A probléma:
    1. Adott egy XP-s hálózat
    2. Beállítottam egy Ubuntu 9.10-t Samba fájlszerverrel
    3. A szerverben van 2 db vinyó.
    4. Az egyiken a rendszer van, a másik egy 500 GB-os üres vinyó.
    linuxos partícióval és egy üres /proba nevű könyvtárral.
    6. Ezt a /proba nevő könyvtárat szeretném megosztani az XP-s gépeknek.
    7. A nagy partíció a /media/Shared pontra van mountolva.
    8. Amíg a rendszerpartíción lévő a bejelentkezett user (mert nem rootként akarom nyilván üzemeltetni) /home könyvtárán belül lévő könyvtárakat osztom meg minden szépen működik.
    9. Viszont a /media/Shared/proba könyvtárat hiába osztom meg, nem tudom elérni, csak kilistázza az XP, ha rá szeretnék tallózni, azt mondja nincs jogom megtekinteni.
    10. Próbáltam a /home könyvtárba is mountolni, de akkor sem volt tallózható.
    11. A könyvtárat természetesen 777 jogokkal létrehoztam a mountolt partíción.

    Az smb.conf így néz ki:

    [global]
    workgroup = WORKGROUP
    netbios name = SZERVER
    guest ok = yes
    read only = no
    security = share
    guest account = nobody

    [proba]
    path = /media/Shared/proba
    available = yes
    guest ok = yes
    read only = no
    browsable = yes
    public = yes
    writable = yes

    Gondolom a mountolással lehet valami gond, szétgugliztam az agyam, de akkor se jöttem rá mi az?
    A mountolást szeretném automatikusra tenni, minden rendszerindulásnál mountolja fel. Szeretném, ha úgy működne, hogy reggel az első ember bekattintja a szervert, az utolsó aki elmegy az meg ki. És perifériák nélkül menne (bill., egér, monitor). Ez megoldható?
    A frissítéseket én hetente 1x majd rátelepítem.

    Először foglalkozom Linuxal, úgyhogy ha nagy dőreség amit kérdezek, előre is bocsi:)!
    Mutasd a teljes hozzászólást!

  • Use
    create mask = 0664
    security mask = 0664
    directory mask = 0775
    directory security mask = 0775
    Mutasd a teljes hozzászólást!
  • Hali!

    Nem fogod elhinni, de megvan a baj:)! A /home mappám egy almappájába mountoltam be a partíciót és azon nem volt 777 jog :).

    Így már okés minden.

    Az automount-ot is sikerült beállítanom az fstab-ben, így mindenféle periféria nélkül szépen működik a fájlszerver.

    Azért köszönöm a segítséget, a megoldásodat elfogadom, mert az vezetett rá, hogy a könyvtárjogokkal lehet a baj.

    Ksözi!
    Mutasd a teljes hozzászólást!
abcd