Excel - göngyölített kigyűjtés
2010-02-05T14:40:08+01:00
2010-02-05T17:49:22+01:00
2022-07-24T22:25:38+02:00
Kikka
Sziasztok!
Lenne egy gond, amiben a segítségeteket kérem!
Egy kimutatást kell készítenem excelben. Több munkalapon dolgozom. Egyik a nyomtatandó táblázat, a többi (kb. 15 munkalap) az adatbázis, végül egy Adatok nevű (szerkesztő)lap. Több száz sor. A munkalapokra INDIREKT paranccsal hivatkozom. A kimutatáson legördülőben változtatom az épület szintjét, a zónáját, és a lekérdezés időpontját (év/hónap). Az adatbázis így épül fel:
A.oszlop: szerkezet típusa (fal, pillér, födém,...)
B.oszlop: szerkezet anyaga (b./vz.)
C.oszlop: beton mennyisége
D.oszlop: betonozás ideje
A kimutatás lapon beállítom melyik hónap utolsó napjáig akarom kigyűjteni az összes betonmennyiséget. A kérdésem az, hogy mi a parancssor, ha a kivitelezés első napjától a beállított hónap utolsó napjáig egy vz. falba összesen mennyi betont nyomtak be. És ennek megfelelően ez az adatbázis később egyéb szerkezetekre is készül, így az összetett képlet tovább bővíthető kell, hogy legyen.
Segítségeteket előre is köszönöm, és várom a jó megoldást! Köszi!
Kikka
Mutasd a teljes hozzászólást!

  • Az adatbázis fgv-eknél nézz körül. Ha minden igaz ABÖSSZEG vagy ilyesmi lesz (DBSUM az angolban).
    Mutasd a teljes hozzászólást!
  • Az adatbázis fgv-eknél nézz körül. Ha minden igaz ABÖSSZEG vagy ilyesmi lesz (DSUM az angolban).
    Mutasd a teljes hozzászólást!
  • Igen, azzal már próbálkoztam. Arra még nem jöttem rá, hogyan tudnék több feltételt megadni neki. Napok óta ezen az egy képleten agyalok, és már minden percben ugyanoda jutok vissza.
    Mutasd a teljes hozzászólást!
  • | A | B | C | D ---+------------+-------+-------+----------- 1 | szerkezet anyag menny időpont 2 | fal b 5 2009.01.15 3 | födém vz 15 2009.01.18 4 | fal vz 20 2009.02.01 5 | fal vz 5 2009.02.08 6 | födém vz 9 2009.02.12 7 | fal b 18 2009.02.19 8 | 9 | 10 | 11 | szerkezet anyag menny időpont 12 | =fal =vz <2009.02.15

    És a képlet:
    =DSUM(A1:D10;"menny";A11:D12)
    (eredménye: 25)

    A kritériumok bárhol lehetnek, de a fejléce egyezzen meg az adatokéval. A kritériumokat a következőképp tudod beírni:
    ="=fal"
    vagy
    ="<2009.02.15"
    Mutasd a teljes hozzászólást!
  • Több feltételes összegzést a Szorzatösszeg függvénnyel lehet megvalósítani.
    Vegyél fel egy új oszlopot, amiben a D oszlop dátumából a Hónap függvénnyel kifejezed a hónapot: =hónap(d2)

    Az összegzés képlete:
    =SZORZATÖSSZEG((A2:A500="fal")*(B2:B500="vz")*(E2:E500=2);C2:C500)

    Az első paraméterben az oszlopokra vonatkozó feltételek szerepelnek zárójelek között, a második az összegzendő terület. Csakis az adatokat tartalmazó lapon működik, és nem fogadja el az (A:A="fal") formát, meg kell adni a kezdő- és a befejező sort.
    Legalább 6 feltételt elbír, eddig kipróbáltam, de azt hiszem, nincs korlát a feltételek számában.

    Mutasd a teljes hozzászólást!
  • Köszi Urak!
    A kritériumok máshol való megadása lehetséges más munkalapon is? Próbálgatom, de még nem az igazi.
    Mutasd a teljes hozzászólást!
abcd