EXCEL tartományban adott érték keresése
2010-03-25T16:53:01+01:00
2010-04-08T18:02:40+02:00
2022-07-25T05:46:09+02:00
MGeorge
Sziasztok,

egy valóban téglalap alakú (nem csak egy sor vagy oszlop!!) tartományban adott értéket megtaláló függvény kellene nekem...
pl.:
D3:E33 tartományban keressük meg az A1 cella értékét, szeretném tudni a sort, oszlopot, ahol megtalálta.

(Igazából a lényeg: ha megtalálta A1 értékét, azt kéne tudnom, ez a 2. sor melyik oszlopában van. Ha C, akkor C2 értéke, ha E, akkor E2 értéke kellene
)
HOL.VAN, INDEX, FKERES függvényeket eddig hiába kombináltam

Tud valaki ebben segíteni? köszi
Mutasd a teljes hozzászólást!
Egymásba ágyazott HA függvényekkel kell megoldani – ha nem kapsz egyszerűbb megoldást. A HOL.VAN függvény csakis 1 sorban, vagy 1 oszlopban tud keresni.

C:G oszlopokban keresésre:

=HA(NEM(HIBÁS(HOL.VAN(A1;C:C;0)));C$2;HA(NEM(HIBÁS(HOL.VAN(A1;D:D;0)));D$2;HA(NEM(HIBÁS(HOL.VAN(A1;E:E;0)));E$2;HA(NEM(HIBÁS(HOL.VAN(A1;F:F;0)));F$2;G$2))))
Mutasd a teljes hozzászólást!

  • Azt hiszem, érthetőbb ha leírom a konkrét problémát:

    egy sorban tárolódnak a vállalat csoportvezetőinek nevei, mindenki neve alatt a csoportjának a tagjai, azaz a beosztottak.
    Ezeket tervezési céllal ide-oda lehet mozgatni, más főnök alá; mindenkinek csak egy főnöke van.

    Az alkalmazottakat egy másik táblázatban tároljuk, az kellene hogy egyszerűen minden alkalmazott mellett ott legyen a főnökének a neve.
    (És ez természetesen tükrözze a fenti táblázatban esedékes változásokat is)

    köszi, MGeo
    Mutasd a teljes hozzászólást!
  • B1-be:
    =HA(HIBÁS(HOL.VAN(A1;D:D;0));INDIREKT("E$2");INDIREKT("D$2"))
    Mutasd a teljes hozzászólást!
  • Nagyon köszi.

    A probléma félig megoldódott így, ahány vezető van, annyiszor egymásba kell ágyazni a HA függvényt :S

    Nincs olyan változata a HOL.VAN-nak, ami nem csak egydimenziós tömbben keres? Akkor

    =HA(HIBÁS(HOL.VAN(A1;D:D;0));INDIREKT("E$2");INDIREKT("D$2"))

    helyett

    =HA(HIBÁS(HOL.VAN(A1;D:G;0));INDIREKT("E$2");INDIREKT("D$2"))

    is lehetne, persze akkor is egymásba kéne ágyazni.
    De most összebarkácsoltam az útmutató alapján :)
    Mutasd a teljes hozzászólást!
  • Egymásba ágyazott HA függvényekkel kell megoldani – ha nem kapsz egyszerűbb megoldást. A HOL.VAN függvény csakis 1 sorban, vagy 1 oszlopban tud keresni.

    C:G oszlopokban keresésre:

    =HA(NEM(HIBÁS(HOL.VAN(A1;C:C;0)));C$2;HA(NEM(HIBÁS(HOL.VAN(A1;D:D;0)));D$2;HA(NEM(HIBÁS(HOL.VAN(A1;E:E;0)));E$2;HA(NEM(HIBÁS(HOL.VAN(A1;F:F;0)));F$2;G$2))))
    Mutasd a teljes hozzászólást!
  • Köszönöm, így működik.

    De azért hasznos lenne egy "advanced" HOL.VAN függvény, így ki lehetne kerülni az egymásba ágyazott HA függvényeket...
    Mutasd a teljes hozzászólást!
  • Szívesen.
    Mutasd a teljes hozzászólást!
  • Írtam egy függvényt kifejezetten ehhez a feladathoz.

    Private Function Csopvez(Ki As String, Tartomány As Range) For Each sz In Tartomány If sz.Value = Ki Then Csopvez = Cells(1, sz.Column) Next End Function

    Hívd be a VB szerkesztőt (Alt+F11), bal oldalon kattints rá a füzeted nevére, Insert menü, Module. A jobb oldalon kapott üres lapra másold be a makrót.
    A füzetbe visszalépve beírod: =csopvez(A1;tartomány)
    A tartomány helyére beírod azt a tartományt, amelyik az emberek nevét tartalmazza.
    Az A1 tartalmazza azt a nevet, akinek a csoportvezetőjét keresed. A képletet le is másolhatod, csak a tartományt fix értékre vedd (pl. $C$1:$G$20).
    Mutasd a teljes hozzászólást!
  • Köszönöm, ez működik!

    Azt hiszem, érdemes beleásni magam az EXCEL terén a VB-be :)
    Mutasd a teljes hozzászólást!
  • Örülök, hogy sikerült, szívesen.
    Mutasd a teljes hozzászólást!
abcd