Excel - Rendezetlen adatokból való szűrés
2010-05-17T10:11:54+02:00
2010-05-18T09:23:46+02:00
2022-07-25T09:31:07+02:00
FinaL
Üdvözletem mindenkinek!

A problémám a következő:
Van egy dokumentumom, amiben van 31 munkalap. Ezekben a munkalapokban nevek szerepelnek egymás alatt (van hogy egy név 2szer is). Továbbá ezek a nevek rendezetlenül állnak csak rendelkezésemre.
De nekem mégiscsak szűrnöm kellene. Ugye az FKERES, VKERES függvényekhez rendezett adatok kellenek. Sokmindent kipróbáltam de nem jutok tovább.

Csináltam egy egyszerűsítettet. Itt a link:
http://www.kepfeltoltes.hu/view/100517/minta_www.kepfeltoltes.hu_.jpg
Remélem érthetően fogalmaztam.
Mutasd a teljes hozzászólást!
A képen nem látszanak a sor- és oszlopazonosítók.
Vegyük, hogy a nevek B3-tól, a hozzájuk tartozó vásárlások C3-tól lefelé találhatóak. A keresett név a H1 cellában van, az 1. vásárlás értékét az F4, a 2. vásárlást pedig a G4 cellában szeretnéd megjeleníteni.

Az A3 képlete legyen
=DARABTELI($B$3:B3;B3)&B3
, figyelj a $ jelekre, és ezt másold le az adataid mellé.

Az F4-be
=HA(HIBÁS(FKERES(1&H1;A:C;3;0));"";FKERES(1&H1;A:C;3;0))
kerül, G4 pedig
=HA(HIBÁS(FKERES(2&H1;A:C;3;0));"";FKERES(2&H1;A:C;3;0))
.

Az A oszlop képleteit írhatod a háttér színével, hogy ne legyenek zavaróak.
Mutasd a teljes hozzászólást!

  • Hali!

    Szűrnöd kell, vagy keresned?
    Amikor ilyen táblában keresek, beszúrok az elejére egy oszlopot, feltöltöm 1-től n-ig, mint sorszám. Utána rendezem név szerint, lefuttatom a kereső függvényt, majd a beszúrt oszlop alapján visszarendezem.

    Primitív megoldás, de nekem bejött
    Mutasd a teljes hozzászólást!
  • Jogos a kérdés. Igazából ki kellene keresnem a feni példán látható "Endre" vevőt, hogy első illetve második vásárlásakor mennyi egységet vett. A megoldásod lehet jó, de 31munkalapon kereszül megcsinálni kissé macerás lenne..
    Mutasd a teljes hozzászólást!
  • Kb 5-6 perces munka:
    1. 'A' oszlopfejen jobb gomb, beszúrás
    2. A1-be 1-et írsz, A2-be 2-t
    3. Kijelölöd A1:A2-t
    4. A kijelölés jobb alsó sarkában lévő kis fekete négyzetre kétszer klikk - automatikusan kitölti addig, amíg van mellette adat.

    Ez kb 7-10 sec * 31 munkalap. De valóban robot meló
    Mutasd a teljes hozzászólást!
  • A képen nem látszanak a sor- és oszlopazonosítók.
    Vegyük, hogy a nevek B3-tól, a hozzájuk tartozó vásárlások C3-tól lefelé találhatóak. A keresett név a H1 cellában van, az 1. vásárlás értékét az F4, a 2. vásárlást pedig a G4 cellában szeretnéd megjeleníteni.

    Az A3 képlete legyen
    =DARABTELI($B$3:B3;B3)&B3
    , figyelj a $ jelekre, és ezt másold le az adataid mellé.

    Az F4-be
    =HA(HIBÁS(FKERES(1&H1;A:C;3;0));"";FKERES(1&H1;A:C;3;0))
    kerül, G4 pedig
    =HA(HIBÁS(FKERES(2&H1;A:C;3;0));"";FKERES(2&H1;A:C;3;0))
    .

    Az A oszlop képleteit írhatod a háttér színével, hogy ne legyenek zavaróak.
    Mutasd a teljes hozzászólást!
  • Ejh ez igen! Köszönöm szépen nagyon sokat segítettetek :)
    Mutasd a teljes hozzászólást!
  • Szívesen.
    Mutasd a teljes hozzászólást!
  • A 31 lapot együttesen kijelölöd a Shift billentyű segítségével, és az aktuálisra beviszed a képleteket, elvégzed a másolásokat. Mindegyik lapon megjelennek a beírások. A bevitel végén meg kell szüntetned az együttes kijelölést, másképp az új változtatások is minden lapon végrehajtódnak!
    Mutasd a teljes hozzászólást!
abcd