Wifi router Wifi AP (TP-LINK) összekapcsolása
2011-04-21T23:48:26+02:00
2011-04-22T13:16:30+02:00
2022-07-27T17:26:32+02:00
scann
A probléma:

Van egy TP-LINK TL-WR542G Router ami Wifi-n (WPA2) és kábelen is osztja a netet több eszköznek. Minden tökéletesen megy.Mellékes, de van még egy Airlive-os eszköz a hálózatban az egyik irányban, ami Repeater-ként osztja továbba netet szintén vezeték nélkül több eszköznek, szintén kifogástalanul.

Szeretnék + 2 eszközt aminek csak kábeles csatlakoztatási lehetősége van hozzáadni a hálózathoz a másik irányban. Sajnos ezek távolban vannak, tehát a TL-WR542G routerhez való kábelezés megoldhatatlan. Gondoltam egyet és vettem egy TP-LINK 743ND AP/Routert amivel kliensént csatlakozok a 542g-hez és az pedig továbbosztja a netet a két eszköznek vezetéken.

743ND-ben Operation Mode- ban kiválasztottam az AP CLIENT Routert ami így WISP Client Routerként működik (tehát a Wireless portja a WAN port). Gondoltam így az 542G lesz úgymond a "WISP."
Wireless Settings alatt beállítottam a titkosítást WPA2-t, így úgy néz ki az 542G beállításaiban, mintha kapna is egy IP-t a 743ND, mert mint Cliens látszik. Azonban a Net nem megy a 743ND-hez csatlakoztatott eszközökön.
A 743ND beállításainál NEtwork alatt WAN Connection type : Dynamic IP -re tettem így elvileg automatikusan kéne kapnia a beállításokat, de egyszerűen nem jelenik meg IP address meg semmi sem.. tehát valami gond itt lehet.
A kábelen csatlakoztatott eszközök kapnak IP-t DHCP-vel a 743ND-től, de net valahogy nem megy, már 3 órát kínlódtam vele.. kiakaszt :)


Lehet, hogy nem is működhet így ? Inkább egy 701Nd -t kellett volna vennem?
Mutasd a teljes hozzászólást!

  • Ez így nem fog menni.
    A Router a WAN portról NATol a LAN portokra. A Wifi LAN oldali (és nem WAN). Ha működne a felállás, további problémával kellene szembenézni, a DuplaNAT-tal - azon a két gépen elég kurtán menne a net. Helyette a következő lehetőségek vannak:
    -annyi AP WLAN->LAN bridge eszköz beszerzése, ahány gép kerül a hálózatba távolabbról (nálad 2). Ez azért kell, mert a WLAN->LAN bridge hitelesít a routerhez kapcsolódáskor; a router egy hitelesítéssel csak 1 IP-t oszt ki, így nem fog menni rajta két gép
    -wifi kártyák használata AP eszköz helyett, közvetlen a gépekhez kötve
    -WDS routerek használata (az 542 nem az, a 743-at nem ellenőriztem)
    -megoldod a kábelproblémát és kihúzol minimum egy kábelt a két géphez, ahol switch-el osztható a jel
    Mutasd a teljes hozzászólást!
  • És ha kicserélném a 743ND-t egy TL-WA701ND -re. És ezzel csatlakoznék az 542G -re Client módban???
    Mert ez nem csak WISP es routerként működik hanem ez kimondottan egy AP ami tud: "Access Point, Multi-SSID, Client, Repeater, Universal Repeater and Bridge with AP"

    "Client: This mode allows the device to act as a wireless station to enable wired host(s) to access an AP"

    Esteleg még a 743ND-t, ha már megvan, betenni a 542G helyére. Az, hogy dupla NAT lenne mondjuk nem érdekes van sávszélesség elég, meg amúgy is a plusz 2 eszköz egy TV és egy Média-Player egymás mellett, de ezek közül egyszerre csak amúgy is csak az egyik használná a netet.


    Mutasd a teljes hozzászólást!
  • van sávszélesség elég


    Kis pontosítás:
    Nem a sávszélesség a gond. A két routernek hevesen kell dolgoznia - feleslegesen, mivel mindkét eszköz címfordítást végez. A kurtított net alatt itt az értendő, hogy egy rakat internetes szolgáltatás (pl uPnP) egyszerűen nem fog működni.

    Kis korrekció az előző hsz-emhez:
    Most láttam, mindkét router támogatja a WDS-t. Mindkét eszközön engedélyezd. A Wifi jelszónak, titkosítási formának a két eszközön azonosnak kell lennie. A 743ND-vel próbálj kapcsolódni az 542G-re Repeater módban. A két eszköz azonos IP tartományban, de különböző címen legyen. A DHCP csak az 542G-n legyen bekapcsolva. Így nem lesz DuplaNAT sem.
    Mutasd a teljes hozzászólást!
  • A gond az "Enable Bridge"-el, hogy ebben az esetben az Wireless Security WEP- re áll automatikusan, ami nekem nem jó, mert az összes eszközt WPA2-vel állítottam be. Az érdekes, hogy az Airlive cucc a másik irányban megy, bár nem is tudom, hogy az mire van állítva,talán - Universal repeater- re azt hiszem, mert nem vagyok most ott. És ahhoz 3 gép is csatlakozik Wifi-n úgy hogy az routerem osztja ki az IP-ket azon keresztül.
    De ez a 743ND AP/router nem tudja.
    Nem jól olvastam el a leírását.

    Bár aztgondoltam, hogy mivel WISP -et tudja, akkor működni fog úgy ,mintha az én 542G-m lenne a Wireless ISP (vezetéknélküli) internet szolgáltató és így már tovább tudja osztani a netet. Mert erre van kitalálva.

    "WISP Internet connection provides local network sharing wirelessly or via cables "

    leírás 14. PDF oldal vagy 7-ik oldal a leírás oldalait nézve. B pont

    De valahogy érzékeli, hogy az egy LAN IP talán.

    De érdekes, mert amikor AP Client Mode -ra megyek a 743ND -ben és a Wireless Setting alatt a Client Setting részen a search-re megyek látja a 542G router általi hálót (48. PDF oldal) és a connect esetén csatlakozik elvileg, és az 542g szerint is kap egy IP-t, WAN nál ilyenkor kéne látni gondolom az IP-t amit kapott, mert pl egy WISP -es szolgáltató is ad IP-t dinamikusat vagy akármilyet, de itt nem kap. Gondoltam én naivan, hogy ilyenkor az lesz a WAN IP amit amásik DHCP-vel kioszt.. de nem kap a 743Nd szerint, viszont az 542G ből nézve igen.
    Kérdés, hogy akkor egy Wireless ISP-s szolgáltató esetén mi van? vagy ők milyen beállításokat használnak, amit a router másként érzékel és a WAN nál megjelennek a IP, subnet stb adatok.?

    Mutasd a teljes hozzászólást!
  • Plusz info:

    az 542G ből nézve Wireless Statistic alatt MAC Address szerint valóban a 743ND -nek a WAN MAC address -e kapja az IP-t és DHCP CLient list alapján is megkapja az IP-t az 542G-ből nézve.

    Viszont akkor ezt miért nem látom a 743ND-ben a WAN alatt? csak 0-k vannak. ÉS renew-ra se történik semmi, pedig a másik szerint kapott egyet.
    Mutasd a teljes hozzászólást!
abcd